注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

早衰男的巢

大音希声 道隐无名

 
 
 

日志

 
 

Android Studio: 真心难适应.. No.1坑:Gradle  

2014-06-20 15:28:06|  分类: android笔记 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
听说口碑一致的好,而且用过就根本停不下来..所以试了一下 Android Studio ,从 Eclipse转IDE过来真心不适应。

安装配置过程还算没什么,界面萌萌哒
项目配置看着感觉很怪,整个结构都不同了。
但对于eclipse过来的用户,一开始遇到的坑想必是 Gradle 看了一个下午的资料,大概知道把它理解成一个编译器

项目import进来后什么也没改动,运行..
提示我
Error:The SDK Build Tools revision (19.0.3) is too low for project ':xxxx'. Minimum required is 19.1.0 
我按提示去修改build.gradle又提示
Error:Gradle: Execution failed for task ':xxxxx:preBuild'.
> failed to find Build Tools revision 19.1.0
又告诉我 19.0.3 太旧,要我改成19.1, 又说没有19.1 这是闹哪样?!摔!!

原来是..............要自己去Andorid SDK管理器里去下载 对应版本的build tools.. 

Android Studio: 真心难适应.. No.1坑:Gradle - 恶 - 早衰男的巢
 
一点都不智能化提示太生涩了..

我想我还会继续用eclipse一段时间..


参考
http://stackoverflow.com/questions/24176846/android-studio-sdk-version-error-after-update

  评论这张
 
阅读(3901)| 评论(1)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018